TechWhirl (TECHWR-L) is a resource for technical writing and technical communications professionals of all experience levels and in all industries to share their experiences and acquire information.
For two decades, technical communicators have turned to TechWhirl to ask and answer questions about the always-changing world of technical communications, such as tools, skills, career paths, methodologies, and emerging industries. The TechWhirl Archives and magazine, created for, by and about technical writers, offer a wealth of knowledge to everyone with an interest in any aspect of technical communications.
Re: "test if" vs. "determine whether" - for API function descriptions ?
Subject:Re: "test if" vs. "determine whether" - for API function descriptions ? From:Robert Lauriston <robert -at- lauriston -dot- com> To:Monique Semp <monique -dot- semp -at- earthlink -dot- net> Date:Tue, 5 Jan 2016 11:47:22 -0800
My default phrasing is "returns TRUE if ...."
On Tue, Jan 5, 2016 at 11:37 AM, Monique Semp
<monique -dot- semp -at- earthlink -dot- net> wrote:
> Hello, WR-L-ers,
> For an API Reference, Iâve got lots (and lots) of descriptions for functions that return TRUE or FALSE depending on whether a given condition/state/whatever is true or false.
> And Iâm wondering which (brief, as in the @brief command in Doxygen) descriptionâs start text might be âbetterâ, âmore quickly grokedâ, âeasier for ESL readers to understandâ:
> * Test if <condition, such as âthe object is the first in the listâ>.
> * Determine whether <condition, such as âthe object is the first in the listâ>.
> Thereâs no consistency in the function names (and I am not about to try to get the code refactored). Names might begin or include âisConditionâ, âConditionâ, âcheckIfConditionâ, and so on; or they might not.
Visit TechWhirl for the latest on content technology, content strategy and content development | http://techwhirl.com